Условное форматирование с использованием формул

В Excel условное форматирование позволяет использовать формулы в критериях вместо значений. В таком случаи критерий автоматически получает результирующие значение, которое выдает формула в результате вычислений.

Условное форматирование по формуле

Формулы в качестве критериев можно использовать практически любые, которые возвращают значения. Но для логических формул (возвращающие значения ИСТИННА или ЛОЖЬ) в Excel предусмотрен отдельный тип правил.

При использовании логических формул в качестве критериев следует:

  1. Выбрать инструмент: «Главная»-«Стили»-«Условное форматирование»-«Управление правилами».
  2. Управление правилами.
  3. В появившемся окне «Диспетчер правил условного форматирования» нажать на кнопку «Создать правило».
  4. Диспетчер правил.
  5. В списке опций «Выберите тип правила:» выберите опцию «Использовать формулу для определения форматируемых ячеек».
  6. Использовать формулу.
  7. В поле ввода «Форматировать значения, для которых следующая формула является истинной» ввести логическую формула, а нажав на кнопку «Формат» указать стиль оформления ячеек.

Правила использования формул в условном форматировании

При использовании формул в качестве критериев для правил условного форматирования следует учитывать некоторые ограничения:

  1. Нельзя ссылаться на данные в других листах или книгах. Но можно ссылаться на имена диапазонов (так же в других листах и книгах), что позволяет обойти данное ограничение.
  2. Существенное значение имеет тип ссылок в аргументах формул. Следует использовать абсолютные ссылки (например, =СУММ($A$1:$A$5) на ячейки вне диапазона условного форматирования. А если нужно ссылаться на несколько ячеек непосредственно внутри диапазона, тогда следует использовать смешанные типы ссылок (например, A$1).
  3. Если в критериях формула возвращает дату или время, то ее результат вычисления будет восприниматься как число. Ведь даты это те же целые числа (например, 01.01.1900 – это число 1 и т.д.). А время это дробные значения части от целых суток (например, 23:15 – это число 0,96875).

Иногда встроенные условия формата ячеек не удовлетворяют всех потребностей пользователей. Добавление собственной формулы в условное форматирование обеспечивает дополнительную функциональность, которая не доступна в строенных функциях данного инструмента. Excel предоставляет возможность использовать много критериев или применять сложные вычисления, что дает широкое поле к применению сложных настроек критериев для автоматически генерированного презентабельного экспонирования важной информации.

Практический пример использования логических функций и формул в условном форматировании для сравнения двух таблиц на совпадение значений.