Как найти сумму числового и функционального ряда

Числовой ряд является некой последовательностью, которая рассматривается совместно с другой последовательностью (ее еще называют последовательностью частичных сумм). Подобные понятия применяются в математическом и комплексном анализе.

Сумму числового ряда можно легко вычислить в Excel с помощью функции РЯД.СУММ. Рассмотрим на примере, как работает данная функция, а после построим график функций. Научимся применять числовой ряд на практике при подсчете роста капитала. Но для начала немного теории.

Сумма числового ряда

Числовой ряд можно рассматривать как систему приближений к числам. Для его обозначения применяют формулу:

Формула суммирования.

Здесь показана начальная последовательность чисел ряда и правило суммирования:

  • ∑ - математический знак суммы;
  • ai - общий аргумент;
  • i - переменная, правило для изменения каждого последующего аргумента;
  • ∞ - знак бесконечности, «предел», до которого проводится суммирование.

Запись Суммирование последовательности чисел. обозначает: суммируются натуральные числа от 1 до «плюс бесконечности». Так как i = 1, то подсчет суммы начинается с единицы. Если бы здесь стояло другое число (например, 2, 3), то суммировать мы начинали бы с него (с 2, 3).

В соответствии с переменной i ряд можно записать развернуто:

Формула суммирования.= а1 + а2 + а3 + а4 + а5 + … (до «плюс бесконечности).

Определение суммы числового ряда дается через «частичные суммы». В математике они обозначаются Sn. Распишем наш числовой ряд в виде частичных сумм:

S1 = а1

S2 = а1 + а2

S3 = а1 + а2 + а3

S4 = а1 + а2 + а3 + а4

Сумма числового ряда – это предел частичных сумм Sn. Если предел конечен, говорят о «сходящемся» ряде. Бесконечен – о «расходящемся».

Сначала найдем сумму числового ряда:

Формула суммы числового ряда.

М = 10.

Теперь построим в Excel таблицу значений членов ряда:

Общий первый аргумент берем из формулы: i=3.

Все следующие значения i находим по формуле: =B4+$B$1. Ставим курсор в нижний правый угол ячейки В5 и размножаем формулу.

Значения с учетом шага.

Найдем значения. Делаем активной ячейку С4 и вводим формулу: =СУММ(2*B4+1). Копируем ячейку С4 на заданный диапазон.

Вычисления значений аргументов. Сумма значений аргументов.

Значение суммы аргументов получаем с помощью функции: =СУММ(C4:C11). Комбинация горячих клавиш ALT+«+» (плюс на клавиатуре).

Функция РЯД.СУММ в Excel

Для нахождения суммы числового ряда в Excel применяется математическая функция РЯД.СУММ. Программой используется следующая формула:

Формула функции РЯД.СУММ.

Аргументы функции:

  • х – значение переменной;
  • n – степень для первого аргумента;
  • m – шаг, на который увеличивается степень для каждого последующего члена;
  • а – коэффициенты при соответствующих степенях х.

Важные условия для работоспособности функции:

  • все аргументы обязательные (то есть все должны быть заполнены);
  • все аргументы – ЧИСЛОвые значения;
  • вектор коэффициентов имеет фиксированную длину (предел в «бесконечность» не подойдет);
  • количество «коэффициентов» = числу аргументов.

Вычисление суммы ряда в Excel

Та же функция РЯД.СУММ работает со степенными рядами (одним из вариантов функциональных рядов). В отличие от числовых, их аргументы являются функциями.

Функциональные ряды часто используются в финансово-экономической сфере. Можно сказать, это их прикладная область.

Например, положили в банк определенную сумму денег (а) на определенный период (n). Имеем ежегодную выплату х процентов. Для расчета наращенной суммы на конец первого периода используется формула:

S1 = a (1 + x).

На конец второго и последующих периодов – вид выражений следующий:

S2 = a (1 + x)2;
S3 = a (1 + x)2 и т.д.

Чтобы найти общую сумму:

Sn = a (1 + x) + a (1 + x)2 + a (1 + x)3 + … + a (1 + x)n

Частичные суммы в Excel можно найти с помощью функции БС().

Исходные параметры для учебной задачи:

Исходные данные.

Используя стандартную математическую функцию, найдем накопленную сумму в конце срока сумму. Для этого в ячейке D2 используем формулу: =B2*СТЕПЕНЬ(1+B3;4)

Функция СТЕПЕНЬ.

Теперь в ячейке D3 решим эту же задачу с помощью встроенной функции Excel: =БС(B3;B1;;-B2)

Функция БС.

Результаты одинаковые, как и должно быть.

Как заполнить аргументы функции БС():

Аргументы функции БС.
  1. «Ставка» - процентная ставка, под которую оформлен вклад. Так как в ячейке В3 установлен процентный формат, мы в поле аргумента просто указали ссылку на эту ячейку. Если было бы указано число, то прописывали бы его сотую долю (20/100).
  2. «Кпер» - число периодов для выплат процентов. В нашем примере – 4 года.
  3. «Плт» - периодические выплаты. В нашем случае их нет. Поэтому поле аргумента не заполняем.
  4. «Пс» - «приведенная стоимость», сумма вклада. Так как мы на время расстаемся с этими деньгами, параметр указываем со знаком «-».

Таким образом, функция БС помогла найти нам сумму функционального ряда.

В Excel есть и другие встроенные функции для нахождения разных параметров. Обычно это функции для работы с инвестиционными проектами, ценными бумагами и амортизационными платежами.

Построение графика функций суммы числового ряда

Построим график функций, отражающий рост капитала. Для этого нам нужно построить график функции являющейся суммой построенного ряда. За пример, возьмем те же данные по вкладу:

Исходные данные.

Дальше нам нужна функция для начисления сложных процентов - БС(). Мы узнаем будущею стоимость инвестиций при условии равных платежей и постоянной процентной ставке. Используя функцию БС(), заполним таблицу:

Данные для графика.

В первой строке показана накопленная сумма через год. Во второй – через два. И так далее.

Сделаем еще один столбец, в котором отразим прибыль:

Прибыль от инвестиций.

Как мы считали – в строке формул.

На основании полученных данных построим график функций.

Выделим 2 диапазона: A5:A9 и C5:C9. Переходим на вкладку «Вставка» - инструмент «Диаграммы». Выбираем первый график:

Вставка графика. График рост капитала.

Сделаем задачу еще более "прикладной". В примере мы использовали сложные проценты. Они начисляются на наращенную в предыдущем периоде сумму.

Возьмем для сравнения простые проценты. Формула простых процентов в Excel: =$B$2*(1+A6*B6)

Формула простых процентов.

Добавим полученные значения в график «Рост капитала».

График сложных и простых процентов.

Какие именно выводы сделает инвестор – очевидно.

Математическая формула частичной суммы функционального ряда (с простыми процентами): Sn = a (1 + x*n), где а – первоначальная сумма вклада, х – проценты, n – период.