Решение экономических задач в Excel и примеры использования функции ВПР

Возможности табличного процессора Excel широко применяются в экономике. С помощью офисной программы можно обрабатывать и анализировать данные, составлять отчеты, бизнес-модели, прогнозировать, определять ценность клиентов и т.д.

В рамках данной статьи рассмотрим использование функции ВПР для решения экономических задач.

Описание и синтаксис функции

ВПР – функция просмотра. Формула находит нужное значение в пределах заданного диапазона. Поиск ведется в вертикальном направлении и начинается в первом столбце рабочей области.

Синтаксис функции:

Аргументы функции.

Аргумент «Интервальный просмотр» необязательный. Если указано значение «ИСТИНА» или аргумент опущен, то функция возвращает точное или приблизительное совпадение (меньше искомого, наибольшее в диапазоне).

Для правильной работы функции значения в первом столбце нужно отсортировать по возрастанию.

ВПР в Excel и примеры по экономике

Составим формулу для подбора стоимости в зависимости от даты реализации продукта.

Изменения стоимостного показателя во времени представлены в таблице вида:

Стоимость.

Нужно найти, сколько стоил продукт в следующие даты.

Назовем исходную таблицу с данными «Стоимость». В первую ячейку колонки «Цена» введем формулу: =ВПР(B8;Стоимость;2). Размножим на весь столбец.

Функция вертикального просмотра сопоставляет даты из первого столбца с датами таблицы «Стоимость». Для дат между 01.01.2015 и 01.04.2015 формула останавливает поиск на 01.01.2015 и возвращает значение из второго столбца той же строки. То есть 87. И так прорабатывается каждая дата.

Пример.

Составим формулу для нахождения имени должника с максимальной задолженностью.

В таблице – список должников с данными о задолженности и дате окончания договора займа:

Список должников.

Чтобы решить задачу, применим следующую схему:

  1. Для нахождения максимальной задолженности используем функцию МАКС (=МАКС(B2:B10)). Аргумент – столбец с суммой долга.
  2. Так как функция вертикально просматривает крайний левый столбец диапазона (а суммы находятся во втором столбце), добавим в исходную таблицу столбец с нумерацией.
  3. Чтобы найти номер предприятия с максимальной задолженностью, применим функцию ПОИСКПОЗ (=ПОИСКПОЗ(C12;C2:C10;0)). Тип сопоставления – 0, т.к. к столбцу с долгами не применялась сортировка.
  4. Чтобы вывести имя должника, применим функцию: =ВПР(D12;Должники;2).
Имя должника.

Сделаем из трех формул одну: =ВПР (ПОИСКПОЗ (МАКС (C2:C10); C2:C10;0); Должники;2). Она нам выдаст тот же результат.

Пример1.

Функция ВПР в экономических расчетах полезна, когда нужно извлечь определенное значение из огромного диапазона данных. Причем это значение нужно найти по другому значению (цену по идентификатору продукта, налоговую ставку по уровню дохода и т.п.).

Использование Excel в экономике не ограничивается функциями просмотра. Табличный процессор предлагает пользователю возможности и побогаче.