Расчет среднего заработка для отпускных в Excel

Правильный расчет отпускных волнует бухгалтеров, кадровиков (больше – даты и сроки) и самих работников. С помощью средств Excel некоторые расчетные операции можно автоматизировать. Рассмотрим варианты создания простых программок.

Расчет количества дней отпуска

Составим программку для контроля количества положенных работнику дней отпуска. Государственные праздники не входят в отпускные периоды. Поэтому сначала сделаем таблицу в Excel с государственными праздниками.

Чтобы преобразовать текстовый формат в числовой, используем функцию ДАТАЗНАЧ.

ДАТАЗНАЧ.

Формула объединяет значения ячеек В3, С3 и результат функции ГОД. Чтобы показать даты праздников в прошлом году, ставим «-1». В будущем году – «+1». Для столбца на 2018 год – «+2».

На 2-м листе сделаем табличку для расчета количества дней, положенных к отпуску.

Данные о работнике.

Это первый блок таблицы. Во втором блоке покажем общий стаж, сколько дней отработано за период и сколько дней отпуска положено работнику. Шапка блока:

Шапка.

Чтобы автоматически устанавливалась текущая дата, используется функция СЕГОДНЯ.

Для расчета общего стажа на текущую дату применяем формулу:

Количество отработанных дней – разница между текущей датой и датой приема (=D$3-C4).

Чтобы найти, сколько дней отпуска наработано на текущую дату, используем следующую формулу:

Дней отпуска.

Размножаем формулы на весь столбец.

Третий блок – найдем расчетный период для количества дней отпуска за первый год. Начало периода – ссылка на ячейку с датой приема на работу. Конец периода находим по формуле: =ДАТАМЕС(G4;12)-1, где G4 – начало расчетного периода.

Окончание.

Четвертый блок – данные по отпускам за период. Количество дней отпуска и начальную дату проставляем вручную. Делаем вспомогательный столбец для расчета конечной даты отпуска с учетом праздников. Формула:

Excel прибавляет к начальной дате отпуска количество дней за минусом 1. Затем проверяет наличие праздничных дат в диапазоне. Если таковые имеются, прибавляет их число к количеству отпускных дней.

Формула для расчета конечной даты отпуска:

Конечная дата.

Общее число отгулянных дней нашли по формуле: =ЕСЛИ(ИЛИ(I4="";J4="");0;I4+I5).

По такому же алгоритму формируем данные для второго, третьего и последующих лет работы. В конце таблички можно дать итоговый столбец, где будет рассчитываться количество оставшихся для отпуска дней.

Как рассчитать отпускные за год в Excel

Схема расчета отпускных выглядит так:

  1. Найти сумму заработной платы за год, предшествующий отпуску. Сюда входят только те платежи, которые предусмотрены по контракту. Не учитываются разовые премии, оплата больничного листа, материальная помощь и т.п.
  2. Рассчитать среднемесячный заработок. Для этого сумму годовой зарплаты делим на 12.
  3. Рассчитать средний дневной заработок. Необходимо разделить среднемесячную зарплату на среднее число календарных дней в месяце (29,3).
  4. Средний дневной заработок умножить на количество дней отпуска.

Тимохин И.И. идет в отпуск с 01.02.2016 на 14 дней. Ежемесячный оклад согласно контракту – 20 000 рублей. Предусмотрена надбавка в размере 1 500 рублей ежемесячно и премия 20%.

Расчетный период – с 01.02.2015 по 31.01.2016 гг.

Данные о зарплате работника за период, предшествующий отпуску:

Месяц, оклад, надбавка (процент), данные по больничному листу и материальной помощи вносятся вручную (светло голубые ячейки). Количество дополнительных выплат может быть любым (в зависимости от особенностей предприятия).

Таблица данных о зарплате имеет следующие столбцы для расчетов:

Лист зарплата.

Формулы, которые были использованы для введения данных о зарплате:

  • количество рабочих дней (В3):
  • надбавка (D3): =C3*$D$1
  • фактически отработанное время (Е3) :=ЕСЛИ(I3>0;B3-ЧИСТРАБДНИ(G3;H3);B3)
  • премия (F3):=ЕСЛИ(B3=E3;C3*20%;(C3/30,5*E3)*20%)
  • число дней, когда человек был на больничном (I3)=ЕСЛИ(ИЛИ(G3="";H3="");"";(H3-G3)+1)
  • итого начислено (L3) : =ЕСЛИ(J3<=0;C3+D3+F3+J3+K3;(C3/30,5*E3)+D3+F3+J3+K3)

На отдельном листе делаем еще одну табличку "Производственный календарь" с праздниками в каждом месяце:

Производственный календарь.

На отдельном листе делаем табличку для расчета отпускных:

Расчет отпускных.

Формула для ячейки С2: =зарплата!L3-зарплата!K3-зарплата!J3. В расчет отпускных не входят все дополнительные выплаты. Если они будут в таблице с начислениями, то впоследствии их можно извлечь из конечной цифры.

Входят ли отпускные в расчет отпускных? Нет. Оплата предыдущего отпуска в новый расчет не включается.

По закону расчетный период считается в календарных днях. Если человек отработал месяц согласно графику (без выходных, командировок и т.п.), то этот месяц полностью включается в период.

Для подсчета полных месяцев(C19):

А так же сумма отработанных дней в неполных месяцах(C20):

Обратите внимание! Формулы в ячейках C19 и C20 выполняются в массиве для этого после их ввода следует нажимать комбинацию клавиш CTRL+SHIFT+Enter.

Делаем дополнительную табличку: Расчет отпускных.

Формула для расчета количества дней: =29,3*$H$14+29,3/30*$G$6.

Формулы для расчета средней заработной платы и отпускных:

Точно так же рассчитываются отпускные при увольнении в Excel и компенсации за неиспользованный отпуск.

Чтобы рассчитать отпускные по уходу за ребенком в Excel, нужно выполнить следующие операции:

  1. Найти средний заработок за два предшествующих отпуску календарных года.
  2. Полученную величину разделить на количество календарных дней расчетного периода.
  3. Средний дневной заработок умножить на 30,4 и на 40%.
Материалы:

Для применения алгоритма подойдут приведенные выше таблицы и формулы.